Page 1 sur 1

´problème décharge applets

Posté : mer. déc. 02, 2009 1:52 pm
par Martin
Depuis plusieurs jours je n'arrive pas à décharger les applets dans les pages des utilisateurs. Y-a-t-il un problème avec le serveur?

Posté : mer. déc. 02, 2009 7:16 pm
par yves974
Vient de vérifier. Chez moi sur les pages de la galerie des utilisateurs c'est OK

Peut-être vider le cache de ton java (faut aller un peu dans le système pour faire ça) ça peut arriver si tu fais plusieurs choses en java en même temps

Posté : jeu. déc. 03, 2009 1:44 pm
par Martin
Peut-être vider le cache de ton java (faut aller un peu dans le système pour faire ça) ça peut arriver si tu fais plusieurs choses en java en même temps[/quote]

Comment le faire? maintenant chaque fois que je veux décharger un applet apparaît un message d'erreur, le navigateur ne tente même pas la connexion. J'ai essayé de tout redémarrer, même résultat.

Posté : jeu. déc. 03, 2009 4:50 pm
par Martin
Voici ce qu'affiche l'ordinateur quand on demande les détails de l'erreur:
cargar: clase rene.zirkel.ZirkelApplet.class no encontrada.
java.lang.ClassNotFoundException: rene.zirkel.ZirkelApplet.class
at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: open HTTP connection failed:http://db-maths.nuxit.net/CaRMetal/user ... lass.class
at sun.plugin2.applet.Applet2ClassLoader.getBytes(Unknown Source)
at sun.plugin2.applet.Applet2ClassLoader.access$000(Unknown Source)
at sun.plugin2.applet.Applet2ClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
... 7 more
Excepción: java.lang.ClassNotFoundException: rene.zirkel.ZirkelApplet.class
cargar: clase rene.zirkel.ZirkelApplet.class no encontrada.
java.lang.ClassNotFoundException: rene.zirkel.ZirkelApplet.class
at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: open HTTP connection failed:http://db-maths.nuxit.net/CaRMetal/user ... lass.class
at sun.plugin2.applet.Applet2ClassLoader.getBytes(Unknown Source)
at sun.plugin2.applet.Applet2ClassLoader.access$000(Unknown Source)
at sun.plugin2.applet.Applet2ClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
... 7 more
Excepción: java.lang.ClassNotFoundException: rene.zirkel.ZirkelApplet.class

Posté : jeu. déc. 03, 2009 7:55 pm
par Martin
J'ai éssayé de changer de navigateur, même problème.

J'ai éssayé avec les pages de Carzine, pas de problème, les applets chargent bien!

ce sont celles sur la page de CarMetal qui ne chargent pas.

Posté : jeu. déc. 03, 2009 9:03 pm
par yves974
Hyper surprenant

Bon quel est to système d'exploitation déjà

Si Linux, préciser lequel ...

Posté : jeu. déc. 03, 2009 9:29 pm
par Martin
yves974 a écrit :Hyper surprenant

Bon quel est to système d'exploitation déjà

Si Linux, préciser lequel ...
je travaille sur windows xp.

J'ai éssayé avec internet explorer et avec firefox. J'ai actualisé le java.

Posté : jeu. déc. 03, 2009 9:56 pm
par Martin
Je viens d'essayer avec ce tutoriel http://db-maths.nuxit.net/CaRMetal/diap ... nsaffines/, il fonctionne bien.

Ce sont les fichiers sous le repertoire user_galery qui posent le problème.

Posté : sam. déc. 05, 2009 10:20 am
par monique31
Martin a écrit :Ce sont les fichiers sous le repertoire user_galery qui posent le problème.
Le problème est-il toujours présent ? Parce qu'avec mon windowsXP et Firefox je n'ai aujourd'hui aucun problème avec ce repertoire user_galery ...

Posté : ven. déc. 18, 2009 2:23 pm
par Martin
monique31 a écrit :
Martin a écrit :Ce sont les fichiers sous le repertoire user_galery qui posent le problème.
Le problème est-il toujours présent ? Parce qu'avec mon windowsXP et Firefox je n'ai aujourd'hui aucun problème avec ce repertoire user_galery ...
Je suis desesperé, le problème persiste. Sous conseil d'un informaticien j'ai desinstallé le java et je l'ai réinstallé, sans succès. Je comprends que c'est un problème particulier de ma machine, et je remercie tout conseil qui puisse me sortir de l'impasse

Posté : ven. déc. 18, 2009 3:56 pm
par alain974
desinstallé le java et je l'ai réinstallé
Sous Ubuntu il y a plusieurs Java, l'un qui est indépendant, et l'autre pour le navigateur Internet. Si c'est pareil sous Windows, le problème ne vient peut-être pas de la machine mais de l'explorateur: Ce qui marche sous Mozilla ne marche pas toujours sous Internet Explorer, et réciproquement d'ailleurs. Si le problème est intermittent le cache doit être vidé, et ça peut venir du fournisseur.

Sous Internet Explorer il doit y avoir une "console java" (dans "outils") et en l'activant, on comprend parfois mieux d'où vient le problème (en y mettant beaucoup de temps quand même...)

Posté : ven. déc. 18, 2009 5:24 pm
par Martin
finalement on a résolu ce problème, on est entré dans la console de java et vidé le caché, après les applets ont bien chargé.