Le bug des élèves

Ceux qui souhaitent signaler des erreurs éventuelles du logiciel sont les bienvenus ici (soyez précis svp !).
Post Reply
Hesperion
Posts: 260
Joined: Sun Nov 11, 2007 2:14 pm
Location: Blois

Le bug des élèves

Post by Hesperion » Tue May 26, 2009 11:28 pm

Pendant longtemps je n'ai jamais réussi à reproduire une bug élève.

Le voici :
Avec leur (mauvaises) habitudes de cliquer trop vite, nos chers petits créent souvent des points aux mêmes endroits que des points déjà existants (par exemple intersection)

Le problème qu'il se pose ensuite lors de la manipulation de la figure est la sélection du bon objet mathématique. Il n'y a normalement pas de problème puisqu'en cliquant une petite fenêtre apparait nous invitant à préciser l'objet qui nous intéresse.

Et là, c'est le drame.
Toujours pressés de cliquer, ils cliquent n'importe où et n'importe comment, font disparaitre la petite fenêtre d'où une impossibilité de commander à nouveau le logiciel.


J'ai essayé pendant un certain temps avec un segment et la droite supportant ce segment (le tout vertical pour des commodités de clics)
Avec un peu d'habitude, j'ai compris comment le faire planter à chaque fois : il faut cliquer sur le double objet pour que l'invite apparaisse puis, sans relâcher la souris, glisser sur le haut de la fenêtre d'invite et relâcher la souris.

Eric, could you fix this please ? :cry: :cry:

User avatar
yves974
Posts: 268
Joined: Tue Oct 30, 2007 3:11 am
Location: Réunion

Post by yves974 » Wed May 27, 2009 10:15 pm

Et pas que des élèves, d'autres cliquent un peu trop vite aussi ;-)

En attendant une éventuelle correction, merci déjà du tuyau qui explique comment de temps en temps on plante le logiciel : en faisant plusieurs heures de CarMetal par jour, certaines semaines, ça m'est arrivé plusieurs fois aussi.

monique31
Posts: 373
Joined: Sat Nov 03, 2007 3:33 pm
Location: Toulouse

Re: Le bug des élèves

Post by monique31 » Wed May 27, 2009 11:09 pm

Hesperion wrote:j'ai compris comment le faire planter à chaque fois ...
Cocasse : la manip que tu donnes fait planter le logiciel sous windows XP ... mais pas sur Ubuntu ; où alors tout simplement il ne se passe rien ; donc on recommence jusqu'à ce que çà marche. Un bon moyen pour apprendre la bonne manip :-)
Et je suppose que c'est pareil sur un Mac.

Hesperion
Posts: 260
Joined: Sun Nov 11, 2007 2:14 pm
Location: Blois

Post by Hesperion » Thu May 28, 2009 1:37 pm

Sous Vista aussi la manip est la même.

Et alors sous Ubuntu, ça plante ou pas ?

monique31
Posts: 373
Joined: Sat Nov 03, 2007 3:33 pm
Location: Toulouse

Post by monique31 » Thu May 28, 2009 2:26 pm

Hesperion wrote:Et alors sous Ubuntu, ça plante ou pas ?
Non, çà ne plante pas ... alors que sous windows çà plante à chaque fois.

User avatar
erichake
Site Admin
Posts: 145
Joined: Sun Oct 28, 2007 11:51 pm
Location: Millau

Re: Le bug des élèves

Post by erichake » Sat May 30, 2009 9:36 am

Hesperion wrote:Pendant longtemps je n'ai jamais réussi à reproduire une bug élève.

Le voici :
Avec leur (mauvaises) habitudes de cliquer trop vite, nos chers petits créent souvent des points aux mêmes endroits que des points déjà existants (par exemple intersection)

Le problème qu'il se pose ensuite lors de la manipulation de la figure est la sélection du bon objet mathématique. Il n'y a normalement pas de problème puisqu'en cliquant une petite fenêtre apparait nous invitant à préciser l'objet qui nous intéresse.

Et là, c'est le drame.
Toujours pressés de cliquer, ils cliquent n'importe où et n'importe comment, font disparaitre la petite fenêtre d'où une impossibilité de commander à nouveau le logiciel.


J'ai essayé pendant un certain temps avec un segment et la droite supportant ce segment (le tout vertical pour des commodités de clics)
Avec un peu d'habitude, j'ai compris comment le faire planter à chaque fois : il faut cliquer sur le double objet pour que l'invite apparaisse puis, sans relâcher la souris, glisser sur le haut de la fenêtre d'invite et relâcher la souris.

Eric, could you fix this please ? :cry: :cry:
Bon sang de bonsoir... J'essaie de reproduire le bug sur windows et je n'y arrive pas...
Tu peux me dire quelle version de java tu utilises ?

A+
Eric

Hesperion
Posts: 260
Joined: Sun Nov 11, 2007 2:14 pm
Location: Blois

Re: Le bug des élèves

Post by Hesperion » Sat May 30, 2009 10:11 am

erichake wrote:Bon sang de bonsoir... J'essaie de reproduire le bug sur windows et je n'y arrive pas...
Tu peux me dire quelle version de java tu utilises ?

A+
Eric
Alors il s'agit de la 1.6.0_13.

monique31
Posts: 373
Joined: Sat Nov 03, 2007 3:33 pm
Location: Toulouse

Re: Le bug des élèves

Post by monique31 » Sat May 30, 2009 10:27 am

Hesperion wrote:Alors il s'agit de la 1.6.0_13.
Idem pour moi :
la 1.6.0_13 pour windows
la 1.6.0_10 pour ubuntu.

Post Reply