Quelle version pour Mac OS X 10.5 (Leopard) ?

Pour tout ce qui concerne l'utilisation du logiciel.
Répondre
elma
Messages : 2
Enregistré le : sam. janv. 07, 2012 3:45 pm

Quelle version pour Mac OS X 10.5 (Leopard) ?

Message par elma »

Bonjour !

J'ai chargé la dernière version de CaRMetal pour Mac OS X (3.7.2 - compatible Lion).

Mais elle refuse de se lancer sur mon Mac Mini (qui est sous Mac OS X 10.5.8 (Leopard)).

Est-ce une incompatibilité connue ?
Quelle est la dernière version de CaRMetal compatible Mac OS X 10.5 (Leopard) ?
Où peut-on la télécharger ?

D'avance merci pour votre aide !

Elma.

monique31
Messages : 373
Enregistré le : sam. nov. 03, 2007 3:33 pm
Localisation : Toulouse

Message par monique31 »

Bienvenue sur le forum, Elma !
La dernière version est compatible Lion, mais fonctionne très bien avec Snow Leopard et probablement Léopard. Alors il faudrait peut-être regarder du côté de "Utilitaires - Préférences Java" ? Quels sont les choix par défaut ?
J'aurais probablement du mal à répondre personnellement puisque je suis passée à Lion, mais j'en connais d'autres qui sont toujours sous Snow Léopard : je leur demanderai.

elma
Messages : 2
Enregistré le : sam. janv. 07, 2012 3:45 pm

Message par elma »

Merci pour la réponse.
J'ai regardé dans le Préférence Java les paramétrages avec un ami qui a Lion et nous avons comparé le réglage, semble quasiment identique, sauf nous n'avons pas la même version Java. Moi, j'ai la version J2SE 5.0. Le problème peut venir de là?
Elma

monique31
Messages : 373
Enregistré le : sam. nov. 03, 2007 3:33 pm
Localisation : Toulouse

Message par monique31 »

Et en regardant du côté de "pomme-mise à jour des logiciels" ?
D'après les forums, il semblerait que la dernière version java proposée par Apple pour Leopard soit du java 6.
D'ailleurs avec Lion, java n'est pas préinstallé (car plus développé par Apple). Il faut l'installer soi-même.

jerome
Messages : 173
Enregistré le : mar. nov. 06, 2007 8:20 pm
Localisation : Saint-Brieuc

Message par jerome »

Même problème,
Sur un vieil eMac, qui ne supporte que Leopard, j'ai fait la bêtise de mettre à jour CaRMetal (version compatible Lion).
Ce qui a eu pour effets :
  • la suppression de l'ancienne version, qui fonctionnait correctement ;
    l'impossibilité de lancer la nouvelle version de CaRMetal.
Je vais tenter de passer de Java 5 à Java 6, mais à première vue Apple ne l'a propose pas pour Leopard.

jerome
Messages : 173
Enregistré le : mar. nov. 06, 2007 8:20 pm
Localisation : Saint-Brieuc

Message par jerome »

Ben non, rien à faire.
Pas de nouvelle version Java pour Leopard
CaRMetal ne se lance pas du tout
La Web start s'installe et signale des erreurs. Voir copies d'écran.
Fichiers joints
Image 1.png
(65.26 Kio) Téléchargé 2222 fois
Image 2.png
(31.94 Kio) Téléchargé 2228 fois
Image 3.png
(51.38 Kio) Téléchargé 2227 fois

Avatar du membre
alain974
Messages : 150
Enregistré le : sam. juin 13, 2009 9:08 am
Localisation : Réunion

Message par alain974 »

jerome a écrit :Pas de nouvelle version Java pour Leopard
Très embêtant ça, et pas seulement pour CaRMetal: Sous Windows Seven, il y a des composantes de LibreOffice que je n'arrive pas à utiliser (JavaScript par exemple) parce que la machine Java la plus récente n'est pas reconnue par LibreOffice. On peut donc espérer que les développeurs d'Oracle vont s'y mettre dans les semaines qui viennent...

En attendant, une solution serait qu'Éric mette en archive les anciennes versions de CaRMetal, mais où?

jerome
Messages : 173
Enregistré le : mar. nov. 06, 2007 8:20 pm
Localisation : Saint-Brieuc

Message par jerome »

J'ai récupéré la version 3.5.2 (elle date du printemps 2010). Je ne peux pas la mettre en pièce jointe, trop lourde, même en zip.
Essayer le lien ci-dessous :
http://dl.dropbox.com/u/28066576/CaRMetal.zip

monique31
Messages : 373
Enregistré le : sam. nov. 03, 2007 3:33 pm
Localisation : Toulouse

Message par monique31 »

Et moi la 3.5.4 (décembre 2010, uniquement le CaRMetal.jar), également téléchargeable sur Dropbox :
http://dl.dropbox.com/u/11005670/CaRMetal354.jar
Evidemment il faut renommer le CaRMetal354.jar en CaRMetal.jar.
Ensuite on n'est pas obligé de désinstaller la 3.7.2 : il suffit de faire un clic-droit dans Applications sur CaRMetal (pour afficher le contenu du paquet) ; aller dans Contents->Resources->Java et remplacer le CaRMetal.jar existant par celui-là.
La 3.5.4 fonctionne-t-elle avec Leopard ? (on risque d'avoir des problèmes avec les macros "vecteurs", refaites pour la 3.7.2)

Répondre